The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
TU demolition will begin on the 3rd floor and the main air handler for the floor will be turned off and will be turned on by July 10.
Posted Jun 30, 2025 - 08:08 EDT
Update
Terminal Unit (TU) replacement began today with floor protection and ceiling removal on the 5th floor, progressing downward through the building.
Posted Jun 23, 2025 - 13:49 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2025 - 07:00 EDT
Scheduled
We will be performing major scheduled utility maintenance at 402 Social Sciences starting on June 23 through August 7. Impact: This project involves replacing the Terminal Units and the Energy Recovery Unit for the building. The project will be taking place at the Social Sciences building, but other surrounding areas including Bartow Avenue and the Visual Arts Loading Dock areas will be impacted. On June 23, the Terminal Unit replacement will begin with floor protection and ceiling removal on the fifth floor, progressing downward through the building. From June 30 through August 7, TU demolition will be taking place on a different floor each week. During this time, the main air handler for the floor will be turned off. From July 7-9, Bartow Avenue will be closed due to the crane and other equipment that will be used to install the new Energy Recovery Unit. On July 8-9, the 4th and 5th floors will need to be vacated.