About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Time Clock Service Issues - Monday, November 27, 2023

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted Nov 27, 2023 - 17:12 EST

Identified

Campus time clocks are currently experiencing issues that may affect your ability to clock in or out.

TCP, our time clock vendor, is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted Nov 27, 2023 - 15:56 EST
This incident affected: Business Operations (Time Clocks).