The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 08, 2024 - 00:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 27, 2024 - 14:34 EST
Scheduled
The network(wired, Wi-Fi, and VoIP Phones) for both the Kennesaw and Marietta campus may experience intermittent unavailability or slowness during system maintenance beginning Sunday, December 8, 2024, 12:00 A.M. extending through Sunday, December 8, 2024, 2:00 A.M..
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.