The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
The 2nd floor restrooms directly adjacent to the Welcome Center are now open and operational. However, work is still underway in the area, so there may still be some debris and noise. All other restrooms in the Student Center are fully operational. Chick-fil-A will open late today and will begin service at 11:00 AM. Please assess any impacts within your area and notify us if you are experiencing additional issues or any critical concerns requiring immediate attention. For questions or assistance, call 470-578-6224 or email plantops@kennesaw.edu.
Posted Apr 02, 2026 - 08:04 EDT
Update
Resolution Strategy: The Plant Operations team is continuing to work on the necessary repairs in coordination with the remediation company.
Timeline: At this time, a confirmed resolution date and time are not yet available. The Plant Operations team is working continuously until the issue is fully resolved.
Ongoing Impact: The 2nd floor restrooms directly adjacent to the Welcome Center will remain offline until repairs are completed. The 1st floor restrooms near Chick-fil-A are now operational. All other restrooms in the Student Center are also operational. Chick-fil-A will remain closed for the rest of the day.
Action Requested: Please assess any impacts within your area and notify us if you are experiencing additional issues or any critical concerns requiring immediate attention. For questions or assistance, call 470-578-6224 or email plantops@kennesaw.edu.
Posted Apr 01, 2026 - 11:27 EDT
Identified
The restrooms located on the 1st and 2nd floor closest to Chick-Fil-A are offline due to an issue within the sewer system. Please direct patrons to use alternate restrooms. After further evaluation, Plant Operations determined that sections of concrete must be removed to access and resolve the sewage issue. Since the situation was considered urgent, they went ahead and moved forward with the necessary repairs. This work will require the use of heavy-duty equipment and will generate significant noise inside the building. We apologize for the disruption this may cause.
Posted Apr 01, 2026 - 10:08 EDT
This incident affected: Utilities & Engineering Services Kennesaw (Campus Water System).