The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Timeline Update: -There has been a delay in receiving the necessary parts for the repair, which has pushed the service date to tomorrow, Tuesday, September 1. -At this time, the completion date remains scheduled for the end of day on Tuesday, September 1. -We anticipate the elevator will resume normal operations by the morning of Wednesday, September 2.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu. For immediate assistance after normal business hours, please call Public Safety at 470-578-6666.
Posted Aug 31, 2026 - 11:06 EDT
Update
Timeline Update: Our elevator contractor has done a thorough assessment of the elevator and is planning to start repairs on Monday, August 31. Updated completion date is now Tuesday, September 1 by the end of business.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu. For immediate assistance after normal business hours, please call Public Safety at 470-578-6666.
Posted Aug 28, 2026 - 15:04 EDT
Update
Timeline Update: -Our elevator contractor has completed their assessment and confirmed that additional parts are required to finalize the repairs. These parts have been ordered and are currently en route, with the vendor expediting shipment as quickly as possible. -We now anticipate that repairs will be completed by the morning of Monday, August 31.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu. For immediate assistance after normal business hours, please call Public Safety at 470-578-6666.
Posted Aug 26, 2026 - 12:55 EDT
Investigating
Current Known Impact: -The elevator is currently out of service due to a failed door‑operator motor. Service is expected to remain unavailable throughout the day tomorrow. -ADA access to the 2nd and 3rd floor classrooms will not be available.
Action Requested: Please assess the impact within your area and let us know if you are experiencing additional issues or critical impacts requiring immediate attention.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu. For immediate assistance after normal business hours, please call Public Safety at 470-578-6666.