About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Housing Portal - StarRez Service Issues - Friday, December 1, 2023

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that the Housing Portal - StarRez is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Dec 04, 2023 - 14:43 EST

Monitoring

The Housing Portal - StarRez is currently experiencing issues that may affect your ability to sign in. If you receive an error, please attempt to sign in again after ten minutes.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted Dec 01, 2023 - 11:54 EST

Investigating

Some users are currently reporting service issues with the Housing Portal - StarRez.

UITS is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Dec 01, 2023 - 10:35 EST
This incident affected: Student Records (Housing Portal - StarRez).