About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

duo.kennesaw.edu Website Login Issues - Tuesday, April 2, 2024
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that the website duo.kennesaw.edu is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Apr 02, 2024 - 10:33 EDT
Identified
The website duo.kennesaw.edu is currently experiencing issues that may affect the ability of new customers to log in and their Duo account and existing customers to update their devices on the website. Customers wishing to add a device or set up their account may contact the KSU Service Desk at (Faculty/Staff) 470-578-6999 or (Students) 470-578-3555, and a technician will be glad to assist you.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Apr 02, 2024 - 09:51 EDT
This incident affected: Accounts & Identity Management (Multifactor Authentication - Duo).