The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 04, 2026 - 17:00 EDT
Scheduled
Impact Details: Description & Location: A break occurred at the main water line in front of Norton Hall today. Plant Operations staff and contractors have located the issue and begun excavation. To complete the repair, the main water line will be shut down this afternoon. The outage will affect the following buildings: 900 Administration Building, 910 Johnson Library, 920 Norton Hall, 955 Recreation & Wellness Center, 622 The Study, 630 CYPHR Research Center, 640 Architecture Building, 970 Shore Innovation Center, Howell Hall, Housing & Residence Life Office, University Commons, and University Courtyard. Schedule: Work is scheduled to begin today, Tuesday, August 4, at 5:00 PM, with water service expected to be restored by midnight. Reason: The outage is necessary to repair a break in the main water line and restore safe, reliable water service to the affected areas. Logistics: All water services—including restrooms, drinking fountains, and labs—will be unavailable in the impacted buildings during the outage. Thank you for your patience and understanding as we work to resolve this issue and restore services. For additional questions, please reach out to Plant Operations 470-578-6224 or email plantops@kennesaw.edu.
Posted Aug 04, 2026 - 12:22 EDT
This scheduled maintenance affected: Utilities & Engineering Services Marietta (Campus Water System).