The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2025 - 07:00 EST
Scheduled
From Friday, November 21, to Wednesday, November 26, KSU Road between Marietta Drive and Paulding Avenue, including both sidewalks, will be closed for Summit II construction. Visitor Lot A will also be closed during this period. Please follow posted detour signs and use Marietta Drive as an alternate route. This closure may affect Big Owl Bus shuttle routes, including service for the home football game on Saturday, November 22. For real-time updates, use the Passio GO! app. For questions or concerns, contact dcs_info@kennesaw.edu.
Posted Nov 12, 2025 - 10:18 EST
This scheduled maintenance affected: Utilities & Engineering Services Kennesaw (Campus Roads and Parking Lots).