The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 16, 2024 - 08:00 EST
Scheduled
Kaltura MediaSpace will be available, but users may experience issues during the upgrade beginning Monday, December 16, 2024, 8:00 a.m. and extending through Monday, December 16, 2024, 12:00 p.m..
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Dec 06, 2024 - 09:02 EST
This scheduled maintenance affected: Academic & Research Services (Kaltura MediaSpace).