The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 18, 2025 - 04:30 EDT
Scheduled
We have identified a leak in a pipe located within the Women's Locker Room on the ground floor of the Convocation Center. The maintenance is scheduled for this Friday, April 18, starting at 4:30 AM and is anticipated to be completed by 7:00 AM in the morning. Please be advised that during this period, domestic water supply to the entire building will be temporarily disconnected. However, this will not impact the fire suppression sprinkler system.
Posted Apr 17, 2025 - 09:29 EDT
This scheduled maintenance affected: Utilities & Engineering Services Kennesaw (Campus Water System).