The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
The scheduled maintenance has been completed, and services are now operational.
Posted Apr 21, 2025 - 09:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 17, 2025 - 11:38 EDT
Scheduled
Our team is continuing to address the elevator outage at 402 Social Sciences Building. As of today, we are in the process of obtaining the necessary parts to conduct repairs. Updates on our progress will be provided as the repairs continue. Impact: Elevator #3 is currently out of order. Other elevators in the building are in service.