The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.
If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.
Use the link below to sign up for text (phone icon) or email (mail icon) updates.
Get email notifications whenever Kennesaw State University creates, updates or resolves an incident.
Get text message notifications whenever Kennesaw State University creates or resolves an incident.
Get incident updates and maintenance status messages in Microsoft Teams channel.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2024 - 07:00 EST
Scheduled
VoiceThread users may experience slowness during system maintenance beginning Saturday, November 16, 2024, 7:00 a.m. and extending through Saturday, November 16, 2024, 11:00 a.m.
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Nov 15, 2024 - 10:22 EST
This scheduled maintenance affected: Academic & Research Services (VoiceThread).