About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

HVAC Outage - 385 Sturgis Library

Incident Report for Kennesaw State University

Resolved

The HVAC outage affecting Sturgis Library has been resolved as of 12:00 PM today. HVAC services have been restored.
Posted Jul 07, 2025 - 12:18 EDT

Update

The contractor is in the process of acquiring additional components that are required to complete the repair.
Posted Jul 07, 2025 - 09:49 EDT

Identified

Our team is continuing to address the HVAC outage at Sturgis Library on the Kennesaw Campus. As of 12:00 PM, the contractor has confirmed that the required parts are currently in transit and are being shipped through overnight delivery. The estimated delivery of the required components is expected by tomorrow morning, July 3. Once the components are received, repairs to the system will commence promptly.
Impact: The HVAC system will remain offline until repairs have been completed.
Posted Jul 02, 2025 - 12:04 EDT
This incident affected: Utilities & Engineering Services Kennesaw (HVAC(Heating, Ventilation, and Air Conditioning) Systems).