The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 11, 2024 - 08:00 EDT
Scheduled
Owl Express/Degree Works, Banner Admin Pages and SAS will be unavailable for system maintenance beginning Saturday, May 11th, 2024, 8:00 A.M. and extending through Saturday, May 11th, 2024, 11:59 P.M.
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Apr 25, 2024 - 14:58 EDT
This scheduled maintenance affected: Student Records (Banner Admin Pages, Banner / Owl Express, DegreeWorks, ePay / Student Accounts) and Business Operations (Event Management System (EMS), KSU Connect, Owl Pay, SAS Reports).