About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

KSU Center Network Service Issues - Thursday, April 11, 2024
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that the KSU Center Network is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Apr 16, 2024 - 15:46 EDT
Identified
The KSU Center Network is currently experiencing issues that may affect your ability to connect to the network or access phones in some areas of the KSU Center.

UITS is currently working to resolve these issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted Apr 11, 2024 - 08:04 EDT
This incident affected: Communications (Campus Telephone System, Network - Kennesaw, WiFi - Kennesaw).