The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 05, 2026 - 07:00 EDT
Scheduled
Impact Details: Description & Location: Water service to the entire Design I building (floors 1 and 2) will be shut off to support sewer line repairs in the patio/planter area between Design I and Design II. Schedule: Friday, June 5 from 7:00 AM – 5:00 PM Reason: A damaged terracotta sewer line was discovered in a planter box as part of the Design II renovation project. Logistics: This outage will affect all domestic water, including restrooms, water fountains, breakrooms, and custodial closets. Faculty/staff/students in Design I may use nearby facilities in the Academic Building or the Engineering Lab for water usage and restrooms. Please feel free to reach out with any questions or specific constraints we should keep in mind. Kindly share this with anyone who may be affected. For questions or concerns, please call the main Campus Operations line at 470-578-6224 or send an email to plantops@kennesaw.edu.
Posted Jun 03, 2026 - 11:26 EDT
This scheduled maintenance affected: Utilities & Engineering Services Marietta (Campus Water System).