About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

HVAC Outage - 402 Social Sciences Building

Incident Report for Kennesaw State University

Resolved

The utility outage affecting Social Sciences has been resolved this afternoon. All services, including HVAC, have been restored.
Posted May 29, 2026 - 15:45 EDT

Update

The Plant Operations team has developed an initial strategy to resolve the ongoing HVAC outage in the Social Sciences Building.
Resolution Strategy:
Plant Operations is working diligently to restore the HVAC system as quickly as possible. The cooling tower has been brought back online, and the team is currently addressing air pockets within the water lines that developed during the full system shutdown.
Timeline:
The goal is to have the system operating under normal conditions by approximately 2:00 PM today.
Ongoing Impact:
As the system stabilizes, some areas may experience intermittent airflow or temperature fluctuations during the restart process.
Communication Moving Forward:
We will continue to provide updates as soon as additional information becomes available. If any unexpected changes occur, we will notify you immediately. For questions or concerns, please contact the Campus Operations main line at 470‑578‑6224 or email Plant Operations at plantops@kennesaw.edu.
Posted May 29, 2026 - 12:02 EDT

Identified

Our team is continuing to address the HVAC outage at 402 Social Sciences Building. Plant Operations is performing emergency repairs to the cooling tower due to a severe leak impacting HVAC system operation. To safely complete the repairs, the building’s HVAC system must be shut down.
At this time, the duration and completion schedule for the work remain unknown. Plant Operations is actively evaluating the repair scope and sequencing requirements to restore service as quickly and safely as possible.

Impact: HVAC System for the entire building is currently out of service.

For additional questions, please call 470-578-6224 or email plantops@kennesaw.edu
Posted May 29, 2026 - 08:39 EDT
This incident affected: Utilities & Engineering Services Kennesaw (HVAC(Heating, Ventilation, and Air Conditioning) Systems).