The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2024 - 19:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 03, 2024 - 11:27 EDT
Scheduled
Network connectivity will be intermittent during system maintenance beginning Tuesday, May 14 at 7:00 p.m. and extending through Wednesday, May 15 at 3:00 a.m.
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.