About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Service Desk Phone Service Issues - Monday, July 15, 2024
Incident Report for Kennesaw State University
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 12:55 EDT
Investigating
Users are currently reporting service issues with the Service Desk phone system. 470-578-3555 and 470-578-6999 are both affected.

If you are experiencing an issue and need technical help - please go to the service portal (service.kennesaw.edu) or send an email to service@kennesaw.edu to submit a ticket.

Our phone provider is currently investigating the issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Jul 15, 2024 - 12:48 EDT