About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

OneUSG Service Issues - November 29th, 2023

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that OneUSG is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Nov 29, 2023 - 15:01 EST

Investigating

Some users are currently reporting service issues with OneUSG.
The University System of GA is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Nov 29, 2023 - 14:25 EST
This incident affected: Business Operations (OneUSG Connect).