The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 12, 2025 - 07:00 EDT
Scheduled
We will be performing scheduled utility maintenance at 3391 Town Point on Saturday, April 12 from 7:00 AM-5:00 PM Impact: During this time, the water supply for the fire suppression system on each floor will be temporarily shut off from 7:00 AM to 5:00 PM. The domestic water system for restrooms, sinks, and drinking fountains, will remain operational and unaffected by this project. If you have questions, please contact Plant Operations at plantops@kennesaw.edu
Posted Apr 10, 2025 - 09:12 EDT
This scheduled maintenance affected: Utilities & Engineering Services Kennesaw (Campus Water System).