About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Zoom Service Issues - Wednesday, 4/16/2025

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 13:05 EDT

Monitoring

Zoom has restored services, they are currently monitoring the situation for stability.
Posted Apr 16, 2025 - 17:03 EDT

Investigating

Some users are currently reporting service issues with accessing and using Zoom.

Zoom is currently investigating these issues and working quickly to fix it.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Apr 16, 2025 - 16:45 EDT
This incident affected: Communications (Zoom Meetings).