About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Degree Works Issue Identified - Tuesday, 03/18/2025

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that Degree Works is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Mar 18, 2025 - 14:00 EDT

Identified

Some users are currently reporting issues with Degree Works, and the UITS team is working quickly to fix the problem.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Mar 18, 2025 - 12:59 EDT
This incident affected: Student Records (DegreeWorks).