About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Water Outage - University Columns- Marietta Campus

Incident Report for Kennesaw State University

Resolved

Repairs to the water lines have been successfully completed, and the water supply has been restored.
Posted Mar 26, 2025 - 18:39 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2025 - 15:34 EDT

Monitoring

We are currently monitoring the water outage affecting University Columns on the Marietta Campus. Water lines are undergoing repairs, and the work is expected to be completed today by approximately 6:00 PM.
Posted Mar 26, 2025 - 15:00 EDT

Identified

Our team is continuing to address the utility outage at University Columns. As of 11:00 AM, water lines were obstructed by a contractor working in the area. The fire system water and domestic water to Houses 6-10 at University Columns are currently out of service until further notice.
Posted Mar 26, 2025 - 13:39 EDT
This incident affected: Utilities & Engineering Services Marietta (Campus Water System).