About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Campus Telephone System - International Calling Service Issues - Tuesday, Novemeber 26, 2024
Incident Report for Kennesaw State University
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 15:21 EST
Investigating
Users are currently reporting service issues with making international calls using the campus VoIP Phones.

UITS is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Nov 26, 2024 - 15:58 EST
This incident affected: Communications (Campus Telephone System).