About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Campus Internet Service Issues - Wednesday, 4/30/2025

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted May 01, 2025 - 13:53 EDT

Update

UITS is continuing to investigate this issue and working to quickly fix it. During this time, Kennesaw campus network speeds may be affected.
Posted May 01, 2025 - 08:24 EDT

Investigating

Some users are currently reporting intermittent service issues while using the campus network.

UITS is currently investigating these issues and working quickly to fix it.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Apr 30, 2025 - 14:05 EDT
This incident affected: Communications (Network - Kennesaw, Network - Marietta, PeachNet Network, WiFi - Eduroam, WiFi - Kennesaw, WiFi - Marietta).