The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 11, 2026 - 06:00 EDT
Scheduled
Impact Details:
Description & Location: A contractor will be cleaning HVAC ducts above the ceilings throughout the building. They will be moving in and out of offices, hallways, and other rooms on all floors (1–2).
Schedule: From early morning Saturday, July 11, through Sunday evening, July 12
Reason: This work is necessary to clean and maintain the HVAC duct system.
Logistics: No preparation is required from occupants. The contractor will cover desks and furniture with plastic sheeting to protect surfaces from any debris and will clean all areas after the work is complete, if needed. Please note that the HVAC system will be turned off on both Saturday and Sunday to support this work, which will result in elevated indoor temperatures during the project.
Please feel free to reach out with any questions or specific constraints we should keep in mind at plantops@kennesaw.edu or call 470-578-6224.
Posted Jul 07, 2026 - 15:02 EDT
This scheduled maintenance affected: Utilities & Engineering Services Marietta (HVAC(Heating, Ventilation, and Air Conditioning) Systems).