The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
New Information: -Parts needed for the repair are currently en route. In the meantime, the HVAC unit is operating as effectively as possible, given the temporary limitations. -At this time, the building is maintaining normal temperatures between 70°F-74°F throughout. -A contingency plan is in place to maintain stable building conditions until full repairs can be completed. -The building is being monitored throughout the day by Plant Operations staff.
Action Requested: Please assess the impact within your area and let us know if you are experiencing additional issues or critical impacts requiring immediate attention.
Communication Moving Forward: We will follow up at a later date with additional information on when to expect repairs to begin.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu.
Posted Aug 25, 2026 - 16:11 EDT
Update
Plant Operations is continuing to monitor temperatures. Further repairs are underway.
Posted Aug 20, 2026 - 15:48 EDT
Update
The building is still currently maintaining temperatures between 72°F and 74°F throughout.
Posted Aug 18, 2026 - 15:25 EDT
Update
New Information: -One of our designated HVAC contractors was onsite yesterday evening to assess why the building was not cooling properly after the cooling tower foaming issue was resolved. Their technician identified a failed chiller bearing module controller.
-The estimated lead time for the replacement controller is approximately 2-4 days.
-Until the controller is replaced, the chiller can operate only with one compressor. To maintain stable building temperatures during this week’s high heat index, the chiller will need to run continuously, 24/7.
-Our priority is to source and replace the controller as quickly as possible to restore full cooling capacity. At this time, the building is maintaining temperatures between 72°F and 74°F throughout.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu. For immediate assistance during after-hours, please call Public Safety at 470-578-6666.
Posted Aug 18, 2026 - 11:34 EDT
Monitoring
New Information: The HVAC system is operating, but it will require additional time to return to its normal setpoint temperature. The Plant Operations team will continue monitoring temperatures this afternoon and again tomorrow morning. A follow‑up update will be sent tomorrow to share progress.
Action Requested: Please assess the impact within your area and let us know if you are experiencing additional issues or critical impacts requiring immediate attention. If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu. During after hour assistance, please call Public Safety at 470-578-6666.
Posted Aug 17, 2026 - 15:47 EDT
Identified
There is a HVAC services disruption at the English Building on the Kennesaw Campus. Current Known Impact: The English Building is currently experiencing an HVAC cooling issue that is affecting building temperatures.
Plant Operations HVAC staff are onsite and actively working to restore normal cooling. A water treatment vendor is also responding to address an issue with the cooling tower that is preventing the chiller from operating properly.
Due to the current outdoor temperatures and heat index, the building will require additional time to return to normal temperature once the system is fully operational. We currently anticipate the building reaching its normal temperature setpoint this afternoon.
Action Requested: Please assess the impact within your area and let us know if you are experiencing additional issues or critical impacts requiring immediate attention.
If you have any questions, please contact Plant Operations at 470-578-6224 or send an email to plantops@kennesaw.edu.
Posted Aug 17, 2026 - 10:05 EDT
This incident affects: Utilities & Engineering Services Kennesaw (HVAC(Heating, Ventilation, and Air Conditioning) Systems).