About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Intermittent Network Issues Identified - Wednesday, 04/23/25

Incident Report for Kennesaw State University

Resolved

University Information Technology Services (UITS) has confirmed that the network is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Apr 24, 2025 - 08:29 EDT

Investigating

Currently, intermittent network issues may impact your ability to connect to our wired or wireless networks.

We know a network connection is important to you, and UITS will provide timely updates as SoX works to correct this issue.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Apr 23, 2025 - 08:07 EDT
This incident affected: Communications (Network - Kennesaw, Network - Marietta, WiFi - Eduroam, WiFi - Kennesaw, WiFi - Marietta).