The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.
If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.
Use the link below to sign up for text (phone icon) or email (mail icon) updates.
Get email notifications whenever Kennesaw State University creates, updates or resolves an incident.
Get text message notifications whenever Kennesaw State University creates or resolves an incident.
Get incident updates and maintenance status messages in Microsoft Teams channel.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Watermark is actively working on a solution. UITS will provide updates as they become available.
Posted Nov 20, 2024 - 17:35 EST
Identified
Watermark (Digital Measures) Course Evaluations and Surveys is currently experiencing issues that may affect your ability to do your course evaluations and surveys.
UITS is currently working to resolve these issues.
You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted Nov 20, 2024 - 12:27 EST
This incident affects: Student Records (Watermark).