The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Power and gas have been fully restored to the Academic Building. All technology systems across the Marietta Campus are now fully operational, and campus-wide gas service has been restored. Follow‑up gas line repairs in the Academic Building are scheduled for tomorrow and are expected to be brief, weather permitting.
Posted Dec 01, 2025 - 19:49 EST
Update
The Academic Building (H) is still without power. All classes and activities in that building were canceled today. All buildings on the Marietta Campus are without gas and internet. Technology systems including Teams Calling, VPN and computer sign-ons are unavailable at this time on the Marietta Campus. Some elevators on the Marietta Campus are temporarily out of service during this time.
Posted Dec 01, 2025 - 16:40 EST
Update
Power to the Academic building is still out and will remain down until the matter is resolved.
Posted Dec 01, 2025 - 14:18 EST
Update
All gas systems across the Marietta Campus have been shut down.
Posted Dec 01, 2025 - 13:33 EST
Identified
We want to inform you of a gas leak that occurred at the Academic Building on the Marietta Campus this morning.
Current Known Impact and Details: Around 9:00 a.m., a gas leak was detected on the 2nd floor of the Academic Building. The building has been fully evacuated by the fire department. Contractors, Environmental Health & Safety and Plant Operations are currently on site assessing the area.
Posted Dec 01, 2025 - 12:23 EST
This incident affected: Utilities & Engineering Services Marietta (HVAC(Heating, Ventilation, and Air Conditioning) Systems, Campus Electrical System, Campus Gas System).