The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2025 - 07:30 EST
Scheduled
Impact Details Description & Location: A Belimo valve will be installed in the plumbing system for Convocation Center. Schedule: The water system will be shut off for 3 hours to conduct the installation from 7:30 AM- 10:30 AM on Wednesday, November 26 . Reason: Installing Belimo valves in our plumbing systems enhances water safety, enables automated leak prevention, and supports smart building integration with reliable, lead-free performance. Logistics: This will affect all domestic water supply on each floor of both the Bailey Performance Center and the Zuckerman Museum including lines for the water fountains, sinks, toilets, and any equipment utilizing water. This will not affect the fire suppression system. If you have questions, please contact us at plantops@kennesaw.edu
Posted Nov 21, 2025 - 13:37 EST
This scheduled maintenance affected: Utilities & Engineering Services Kennesaw (Campus Water System).