About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Multiple Application Service Issues - Friday, July 19, 2024
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that the multiple applications impacted by the worldwide outage are functioning normally now.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Jul 22, 2024 - 14:53 EDT
Update
CampusLogic & VerifyMyFAFSA are now operational. We are continuing to monitor this issue.
Posted Jul 19, 2024 - 11:26 EDT
Update
EAB Navigate is now operational. We are continuing to monitor this issue.
Posted Jul 19, 2024 - 10:54 EDT
Update
Qualtrics is experiencing slowness. We are continuing to monitor this issue.
Posted Jul 19, 2024 - 10:39 EDT
Update
ProctorU is experiencing an outage. We are continuing to monitor this issue.
Posted Jul 19, 2024 - 10:01 EDT
Update
Blackbaud Financial Edge & Raiser's Edge are experiencing an outage. We are continuing to monitor this issue.
Posted Jul 19, 2024 - 09:08 EDT
Identified
Multiple applications are currently experiencing issues that are likely impacted by a worldwide outage affiliated with CrowdStrike and Microsoft.

Some impacted applications include:

CampusLogic
EAB Navigate
VerifyMyFAFSA
Qualtrics
Blackbaud Financial Edge
Raiser's Edge
ProctorU

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Jul 19, 2024 - 08:52 EDT
This incident affected: Student Records (CampusLogic, Navigate EAB), Academic & Research Services (Qualtrics), and Business Operations (Financial Edge, Raiser's Edge).