About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Virtual Owl / ksuview Service Issues - Saturday, 04/19/2025

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted Apr 19, 2025 - 10:54 EDT

Investigating

Some users are currently reporting issues with ksuview.kennesaw.edu, and the UITS team is working quickly to fix the problem.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Apr 19, 2025 - 10:04 EDT
This incident affected: Academic & Research Services (Virtual Owl).