About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

HVAC Outage (Cooling Only) Impacting 385 Sturgis Library

Incident Report for Kennesaw State University

Resolved

Update: We are pleased to confirm that the HVAC (cooling) outage at Sturgis Library has been resolved and the system is now operational.

Thank you for your patience during this time. If you experience any further issues, please don’t hesitate to reach out to plantops@kennesaw.edu.
Posted Feb 20, 2026 - 07:46 EST

Update

New Information:
Repairs to the pump have been further delayed due to additional issues identified during inspection. If work continues as expected, the system should be restored later tonight.
Most areas in the building are now holding between 72–78 degrees, with temperatures continuing to rise. Plant Operations will continue to monitor conditions throughout the day.
We encourage you to plan accordingly and let us know if you experience any critical impacts that require immediate attention. If you have any questions, please call the Campus Operations main line at 470‑578‑6224 or email plantops@kennesaw.edu.
Posted Feb 19, 2026 - 13:14 EST

Update

Repairs are still in progress.
Posted Feb 19, 2026 - 12:37 EST

Identified

Current Known Impact: 
The chilled water pump at Sturgis Library developed a leak that quickly escalated into a critical failure. The contractor was contacted to inspect the issue, and their technicians initially identified faulty shaft seals and bearings. During disassembly, they discovered the pump shaft is warped, preventing proper sealing and normal operation.

Contractors continue to work on the chilled water pump, which has now been fully removed and taken off‑site for repairs. Until the repairs are completed and the pump is reinstalled, the building will remain without cooling.

If you have any questions or concerns, please call ext. 6224 or email plantops@kennesaw.edu. Updates regarding this outage will also be communicated from the KSU Outage Alert resource account.
Posted Feb 18, 2026 - 08:43 EST
This incident affected: Utilities & Engineering Services Kennesaw (HVAC(Heating, Ventilation, and Air Conditioning) Systems).