About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Microsoft 365 Service Issues - November 25, 2024
Incident Report for Kennesaw State University
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 13:49 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 26, 2024 - 08:28 EST
Monitoring
Microsoft has implemented a fix, restoring operation to most affected services.

They are actively working to resolve the remaining service issues.

For further assistance or questions, please reach out to the KSU Service Desk at service@kennesaw.edu.
Posted Nov 25, 2024 - 15:56 EST
Update
Microsoft is continuing to work through these issues.
Posted Nov 25, 2024 - 12:50 EST
Update
We are continuing to investigate this issue.
Posted Nov 25, 2024 - 09:32 EST
Investigating
Some users are currently reporting service issues with Office 365.

Users may be unable to access or use some services and features.

Some users may be unable to sync or send new email messages from Outlook for Mac.

Some users' searches may fail and provide no results in the Outlook desktop client and Outlook on the web.

Microsoft is currently investigating these issues. We will provide further updates as they are available.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu or 470-578-6999.
Posted Nov 25, 2024 - 09:29 EST
This incident affected: Communications (Office 365 / Campus Email).