About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Microsoft Copilot Web Service Issues - Friday, 07/10/26

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 12:21 EDT

Update

Microsoft is continuing to work on a fix for this issue.
Posted Jul 10, 2026 - 14:26 EDT

Identified

Microsoft Copilot Web is currently experiencing issues that may affect your ability to utilize this AI tool on the web.

Microsoft is currently investigating this issue and working quickly to fix it.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Jul 10, 2026 - 14:24 EDT
This incident affected: Productivity Services (Copilot).