About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Isolated Power Outage - Science Lab Building

Incident Report for Kennesaw State University

Resolved

The utility outage affecting the Science Lab Building 3rd floor outlets has been resolved as of 12:30pm.
Posted Jun 18, 2025 - 12:30 EDT

Identified

Our team is addressing an insolated power outage at the Science Lab Building. A breaker tripped affecting the power outlets only on the third floor of the Science Lab building. Repairs are underway and are anticipated to take approximately one hour.
Posted Jun 18, 2025 - 10:32 EDT
This incident affected: Utilities & Engineering Services Kennesaw (Campus Electrical System).