About the KSU Status Page


The KSU Status Page provides up-to-date service information about the status of and upcoming maintenance for Kennesaw State University IT systems and services.

If you are encountering a problem that is not listed on this page, please report your issue to the KSU Service Desk at the KSU Service Portal.

Use the link below to sign up for text (phone icon) or email (mail icon) updates.

Kennesaw Campus Network Potential Slowness - Friday, July 26, 2024
Incident Report for Kennesaw State University
Resolved
University Information Technology Services (UITS) has confirmed that the Kennesaw Network is functioning normally at this time.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.
Posted Jul 26, 2024 - 13:40 EDT
Identified
The Kennesaw Campus Network is currently being monitored for slowness.

UITS is currently working to investigate any potential issues.

You can monitor the status of this and other KSU technology services and subscribe to service alerts at the UITS Status Page at status.kennesaw.edu.

For questions or assistance, please contact the KSU Service Desk at service@kennesaw.edu.
Posted Jul 26, 2024 - 12:31 EDT
This incident affected: Communications (Network - Kennesaw, WiFi - Kennesaw).