The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
The project is now complete, and services are in working order.
Posted Mar 29, 2025 - 09:45 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 29, 2025 - 05:01 EDT
Scheduled
Emergency Power Automatic Transfer Switch will be replaced at the Convocation Center on Saturday, March 29. This project will only impact emergency power and internet services, including data. Please be advised that regular power will not be affected during this time.