About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Marietta Event Center Wi-Fi Issues - Wednesday, 4/30/2025

Incident Report for Kennesaw State University

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 18:09 EDT

Investigating

The Marietta Event Center on the Marietta campus is currently experiencing issues with Wi-Fi.

We know the Wi-Fi connection is important to you, and UITS is working quickly to fix it.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Apr 30, 2025 - 14:29 EDT
This incident affected: Communications (WiFi - Marietta).