The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
The elevator outage inside the Visual Arts Building has been resolved. The system has been tested and is now fully operational.
Posted Apr 24, 2025 - 10:41 EDT
Update
Necessary parts have been received to repair the elevator. Technicians will be on site this morning, April 24 for installation.
Posted Apr 24, 2025 - 05:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2025 - 08:48 EDT
Scheduled
Our team is continuing to address the elevator outage at the Visual Arts Building on the Kennesaw Campus. As of today, we are in the process of obtaining the necessary parts to conduct repairs. Updates on our progress will be provided as the repairs continue. Impact: Elevator is currently out of order.