The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Current Known Impact: The HVAC system for the Music Building is currently not operational. This does not affect MU109 Recital Hall, as it is served by a separate HVAC unit. If your area contains sensitive equipment, it is advisable to store it in the Recital Hall or an alternative location. Temperatures are mild this morning at approximately 69 degrees. However, the forecast indicates that the high may reach up to 79 degrees today, which will result in temperature increases within the building.
New Information: The contractor is continuing repair work and has identified additional parts that needed to be ordered. Work will proceed diligently through today and into next week, with completion anticipated by Friday, October 24.
Action Required: Please assess conditions in your area and report any critical issues that may impact comfort or safety. As internal temperatures may rise throughout the day, class relocation should be considered where appropriate. According to the forecast, outdoor temperatures are expected to remain mild, with highs in the low 70s and overnight lows in the mid 40s.
Posted Oct 17, 2025 - 13:03 EDT
Update
The Plant Operations team and the contractor are on-site performing repairs. They will be working diligently throughout the day and possibly into tomorrow. The completion timeline depends on the availability of necessary parts. Temperatures are mild this morning at approximately 56 degrees. However, the forecast indicates that the high may reach up to 82 degrees today, which will result in temperature increases within the building. As a result, classes may be relocated.
Posted Oct 16, 2025 - 08:38 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 16, 2025 - 07:07 EDT
Identified
Our team is continuing to address the HVAC outage at 491 Music Building.
Current Known Impact: The HVAC system for the Music Building is currently non-operational. This should not affect the Recital Hall, as it is served by a separate HVAC unit. If your area contains sensitive equipment, it may be advisable to store it there.
The contractor has been notified, and a technician is scheduled to begin assessment and repairs first thing tomorrow morning. At this time, we are currently unable to provide a confirmed completion date/time for repairs.
Posted Oct 15, 2025 - 18:08 EDT
This incident affects: Utilities & Engineering Services Kennesaw (HVAC(Heating, Ventilation, and Air Conditioning) Systems).