The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.
Use the link below to sign up for text or email updates.
Get webhook notifications whenever Kennesaw State University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 16, 2026 - 06:00 EDT
Scheduled
Impact Details
Description & Location: Our designated elevator contractor will be on-site next week to perform the required five-year elevator testing. The building has two elevator locations, each with two elevator cabs. All elevator lobbies and elevator cabs involved in testing will be out of service during designated periods.
Schedule: Thursday, July 16 through Friday, July 17, approximately 6:00 a.m. to 2:30 p.m. each day.
Reason: This outage is necessary to complete mandated five-year elevator testing.
Logistics: Each morning, technicians will begin with a drop test at one elevator location. During this test, both elevator cabs at that location will be out of service, and the ground floor lobby must remain clear. The drop test is expected to take 30 minutes to one hour and should be completed before 8:00 a.m. The second elevator location will remain fully operational during the drop test. After the morning drop test, testing will continue throughout the day with only one elevator cab out of service at a time, ensuring three elevators remain in service.
Please feel free to reach out with any questions or specific constraints we should keep in mind at 470-578-6224 or send an email to plantops@kennesaw.edu.
Posted Jul 08, 2026 - 08:21 EDT
This scheduled maintenance affected: Utilities & Engineering Services Kennesaw (Campus Electrical System, Campus Roads and Parking Lots).