About KSU Services Status Page

The Kennesaw State University Services Status page provides real-time updates on the operational status and maintenance of essential KSU services, including Information Technology and Utilities and Engineering.

Use the link below to sign up for text or email updates.

Technology Outage - Monday, 12/01/25

Incident Report for Kennesaw State University

Resolved

All technology services have been fully restored. For updates regarding the Academic Building gas leak, please visit https://status.kennesaw.edu.
Posted Dec 01, 2025 - 19:22 EST

Update

WiFi and Wired network have been restored on the Marietta Campus
Posted Dec 01, 2025 - 17:52 EST

Identified

WiFi has been restored on the Kennesaw Campus.
Posted Dec 01, 2025 - 13:42 EST

Investigating

A gas leak was detected in the Academic Building on Marietta Campus. For safety, all technology systems there are shut down, affecting network, Teams Calling, VPN, and computer sign-ins. Some services in Kennesaw may also be disrupted. UITS staff are coordinating with Facilities, Public Safety, and our external providers to remedy the issue. Safety teams are monitoring conditions closely. We will provide updates as additional information becomes available and systems are restored.

Have questions? Call 470-578-6999 or email service@kennesaw.edu
Posted Dec 01, 2025 - 11:44 EST
This incident affected: Accounts & Identity Management (Authentication Services), Productivity Services (Global Protect VPN), and Communications (Network - Marietta, Teams Calling, WiFi - Kennesaw, WiFi - Marietta).